North American SMS Delivery Disruption

Incident Report for RMS Cloud

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 04:23 UTC

Investigating

Our team are investigating reports of intermittent SMS delivery problems affecting North American customers. Further updates will be provided as soon as they're available.
Posted Jul 01, 2026 - 00:39 UTC
This incident affected: Modules (RMS SMS Module).